Excel’de Düşeyara (Vlookup) Nasıl Kullanılır?

Düşeyara Excel’de en sık kullanılan ve en önemli formüllerden biridir. Bir tabloda bulunan veriler arasından aramak istediğimiz bir değerin onunla bağlantılı olan diğer değerlerini bulmamızı sağlar. Örneğin bir firmadaki satış temsilcisinin hangi ürünleri sattığını, hangi bölgelere satış yaptığını yada hangi tarihlerde satış yaptığını öğrenmek istiyorsak düşeyara işlevini kullanırız.

Düşeyara işlevi bazı durumlarda farklı tablolarda bulunan değerleri yeni bir yere getirmemizi sağlar. Ancak bunu sağlayabilmek için bir şartımız var. O da her tabloda ortak bir değerin varlığı. Örneğin ürün kodu, hesap numarası, Tc numarası gibi benzersiz değerlerin varlığı.

Aşağıdaki örnekte ürün kodları ortak olan iki farklı tablo yan yana verilmiştir. Mavi renkli tablo satış tablosudur. Kırmızı renkli tablo ise ürün bilgileri tablosudur.  Her gün farklı ürünlerin satışları olacağından satış tablosunun açıklama kısmına o ürünün ismi gelmesi gerekir. İşte burada Düşeyara işlevini kullanarak satılan tüm ürünlerin isimlerini otomatik olarak getirebiliriz. Peki nasıl olacak?

ekran-resmi-2016-11-12-23-11-09

Öncelikle Düşeyara işlevinin formül açılımını yazalım.

=DÜŞEYARA(Aramak istediğiniz değer; değeri aramak istediğiniz aralık; aralıkta dönüş değerini içeren sütunun numarası; 0/YANLIŞ veya 1/DOĞRU olarak gösterilen Tam Eşleşme veya Yaklaşık Eşleşme)

Bu örnekte Düşeyara işlevini E2 hücresine uygulayacağız.Yani mavi tablodaki Açıklama sütununun ilk hücresine.

=DÜŞEYARA(A2;$H$2:$J$10;2;YANLIŞ)

A2 :Aramak istediğiniz değer(Aranan Değer)

Ürün kodları her iki tabloda ortak olduğundan aramak istediğimiz değerin açıklamasını kırmızı tablodan çağıracağız.

$H$2:$J$10 :değeri aramak istediğiniz aralık( Tablo Dizisi)

Aradığımız değerin bilgisi hangi tablo veya aralıktaysa tümünün seçili olması gerekir.
Not: Aradğımız değerin bilgisi tablo halinde değilse yani sade bir aralıksa örnekte olduğu gibi tüm aralığı seçip mutlak adresleme yapmamız(F4 tuşuna basmamız) gerekir.
2: aralıkta dönüş değerini içeren sütunun numarası(Sütun İndis Sayısı)

Burada 2 sayısının anlamı kırmızı tablodaki ürün açıklamasının kaçıncı sütunda olduğunu ifade eden durumdur. Kırmızı tablo üç sütunlu bir tablo olduğu için ürün açıklaması ikinci sütundadır. O yüzden sütun indis sayısı 2’dir.
YANLIŞ: Aradığımız değerde tam eşleşme yapmak için kullanırız.(Aralık Bak)

Varsayılan ayar YANLIŞ olarak geçer. Bu seçenek genellikle bu şekilde kalır.

ekran-resmi-2016-11-12-23-39-24

ekran-resmi-2016-11-12-23-40-48

Görüldüğü üzere Düşeyara formülünü yazdıktan sonra aynı formülü diğer hücrelere de uyguladığımızda tüm satılan ürünlerin açıklamaları diğer hücrelere de hatasız gelmiş olur.